« iTunes-LAMEとiTunes 12 | トップページ | Lotus Notes 8.5.2がサーバーにつながらない »

2014年11月15日 (土)

MacPorts 2.3.2とGnumeric 1.12.18

MacPortsのバージョンが2.3.2に上がっていた。Gnumericも1.12.8から最新の1.12.18へ上がっていたのでupgradeした、のだけどトラブル。

環境はMacBook Pro 13" 2009にOS X Mavericks 10.9.5。最近Xcode 6.0.1やCommand Line Tool 6.1のアップデートをしたばかり。

いつものようにsudo port self updateでMacPortsをアップデートしようとしたら、エラーが出てしまった。
dummyusername@Exerion$ sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.3.1 installed,
MacPorts base version 2.3.2 downloaded.
--->  Updating the ports tree
--->  MacPorts base is outdated, installing new version 2.3.2
Installing new MacPorts release in /opt/local as root:admin; permissions 0755
Error: Error installing new MacPorts base: command execution failed
Please run `port -v selfupdate' for details.
Error: /opt/local/bin/port: port selfupdate failed: Error installing new MacPorts base: command execution failed

このままGnumericをアップデートしようとすると次のエラーになる。

dummyusername@Exerion$ sudo port upgrade gnumeric
Password:
Error: It seems you have not accepted the Xcode license; most ports will fail to build.
Error: Agree to the license by opening Xcode or running `sudo xcodebuild -license'.
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

よく読むとXcodeを起動してライセンスに同意しろとある。そういえばXcordeはインストールしただけで起動したこと無いなと思い、立ち上げてライセンスに同意する。

その後再度実行したら、問題なくアップグレード完了。
Gnumeric 1.12は使っているライブラリのせいなのか、グラフの設定パネルの表示がおかしかったのだけど、1.12.18でようやく直った。OS Xだと相変わらず日本語入力できないけど、これは仕方がないかな・・・

|

« iTunes-LAMEとiTunes 12 | トップページ | Lotus Notes 8.5.2がサーバーにつながらない »

Mac OS X」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック


この記事へのトラックバック一覧です: MacPorts 2.3.2とGnumeric 1.12.18:

« iTunes-LAMEとiTunes 12 | トップページ | Lotus Notes 8.5.2がサーバーにつながらない »